Doc-To-Help 5 System Requirements

 Article #: IAR1004D  Product: Doc-To-Help   Version: 5

Summary:

The following is the listing of system requirements to run MadCap Doc-To-Help 5.

Full Description:

An Internet Connection is required to download certain components of the Requirements (.NET Framework)

  • PC with Intel® Pentium® II 500 MHz or greater processor

  • 512 MB of RAM Minimum

  • 200 MB of hard disk space for the Doc-To-Help application and related files

  • Windows 7 Service Pack 1, Windows 8, Windows Server 2008 R2 SP1, Windows Server 2008 Service Pack 2, Windows Server 2012, Windows Vista Service Pack 2, Windows 10

  • Microsoft® Word 2010, Microsoft® Word 2013, or Microsoft® Word 2016

  • Microsoft® .NET Framework version 4.5.1 or later

    • The Doc-To-Help installation will check for the presence of the Microsoft .NET Framework 4.5.1. If not found, it will be installed automatically.

  • Microsoft® Internet Explorer® 9 or greater (for use by the Theme Designer), Google Chrome, Mozilla Firefox, or Safari

  • Visual Studio 2010 Tools for Office Runtime

    • The Doc-To-Help installation will check for the presence of the Visual Studio 2010 Tools for Office Runtime. If not found, it will be installed automatically

If using Doc-To-Help's SharePoint integration, Doc-To-Help collaboration features are compatible with Microsoft® SharePoint® 2007, 2010, and 2013, as well as Office 365 (SharePoint Online). SharePoint 2010 or 2013 is required when publishing Doc-To-Help Targets to a SharePoint Wiki Library. SharePoint 2010 is recommended when working with Translation Libraries (SharePoint 2013 does not include this feature). Translation Libraries cannot be managed in Windows SharePoint Services 3.0, because WSS 3.0 does not support them.

Prerequisite for Office 365 (SharePoint Online):

Supported operating systems for Office 365:

Windows 10, Windows 7, Windows 8, Windows Server 2008 R2, Windows Server 2008 Service Pack 2, Windows Vista Service Pack 2.

If storing your Team Project in a Team Foundation Server repository, Doc-To-Help supports Microsoft Team Foundation Server 2008, 2010, 2012, 2015 and 2017.

Note: D2H does not support side-by-side installations by design.

MadCap products currently require Microsoft Windows. Several users have installed Windows on their Macs using programs that enable them to run Windows. The system requirements remain the same for the version of Windows running on a Mac.

If there are difficulties installing Doc-To-Help after fulfilling the items on this checklist, please contact MadCap Technical Support.

Attribution:

Last updated:

9/11/2017

Author:

Tyler Hubbard

Contributions by:

MadCap QA

 


Copyright © 2018 MadCap Software Inc. All rights reserved.