MadCap Lingo 11 r2 System Requirements

 Article #:IAR1011L  Product: Lingo   Version: Lingo 11 r2

Summary:

The following is a listing of system requirements to run Madcap Lingo 11 r2.

Full Description:

An Internet Connection is required to download certain components of the requirements

  • 8 GB memory (RAM)
  • 820 MB available hard drive space
  • Windows 10, 32 or 64 bit, including all required updates
  • Microsoft .NET Framework 4.6
  • Source Control integration supports the following
    • Team Foundation Server 2010, 2012, 2013, 2015, 2017, or 2018
    • Subversion 1.5.3, 1.6, 1.7, 1.8 or 1.9, GIT 1.9.4
    • Perforce Helix Core 2014.1, 2015.2, 2018.2
    • Git integration using Git.exe requires version 2.21 and higher.
      • Git.exe is not required for Git integration but provides improved performance
  • Microsoft PowerPoint 2007 or greater with the latest service pack (for translating PowerPoint documents with the .ppt extension)
  • Adobe FrameMaker version 8.0 or greater with Distiller (for translating FrameMaker documents with the .fm and .book extensions)
  • Equation rendering in preview requires Java Runtime Environment (JRE) version 7.51 or OpenJDK 1.8
  • EPS images rendering in preview requires Ghostscript
  • Google Chrome, Mozilla Firefox, and Internet Explorer 11 and Edge

For Translating File Types:

  • Power Point: Microsoft PowerPoint 2007 or greater with the latest service pack (for translating PowerPoint documents with the .ppt extension)
  • Adobe FrameMaker: FrameMaker version 8.0 or greater with Distiller (for translating FrameMaker documents with the .fm and .book extensions)
  • Microsoft Word and Excel: Microsoft Word and Excel are not needed to import / export Word and Excel files.

Translation Memory:

If you wish to use Lingo's Translation Memory capability you must use one of the following:

  • To create server-based Lingo translation memory databases:
    • Microsoft SQL Server 2008 (or newer) Express Edition
    • Microsoft SQL Server 2008 (or newer) Standard Edition
  • To create local Lingo translation memory databases:
    • SQLite version 3.8.8.3 (Included with Lingo)
  • To use Machine Translation user must have an account with one or more of the following providers and an Internet connection
    • Google Translate
    • Microsoft Bing Translator
    • MyMemory Translated.net
    • DeepL Translator1

Termbase Capabilities

If you wish to use Lingo's Termbase capability you must use one of the following:

  • To create server-based Lingo Termbases:
    • Microsoft SQL Server 2008 (or newer) Express Edition
    • Microsoft SQL Server 2008 (or newer) Standard Edition
  • To create local Lingo Termbases:
    • SQLite version 3.8.8.3 (Included with Lingo)

Attribution:

Last updated:

08/03/2020

Author:

Marvin Mallari

Contributions by:

MadCap QA